[Intelmq-users] IntelMQ on CentOS7 - yum update failling with conflicting files

Marco Paulo Machado Teixeira marco at scom.uminho.pt
Thu Jun 18 13:27:59 CEST 2020

Hello Sebastian,
Thank you for you help.

Should have mentioned that already tried that, but dependencies ask to remove IntelMQ... Would you say it's safe to force removal of the package, ignoring dependencies, and just install the EPEL packet afterwards?

Dependencies Resolved

 Package                 Arch         Version           Repository                 Size
 python3-dnspython       noarch       1.15.0-3.6        @home_sebix_intelmq       1.3 M
Removing for dependencies:
 intelmq                 noarch       2.1.0-1.1         @home_sebix_intelmq       234 k
 intelmq-doc             noarch       2.1.0-1.1         @home_sebix_intelmq       907 k
 intelmq-manager         noarch       2.1.0-1.2         @home_sebix_intelmq       9.6 M
 python3-intelmq         noarch       2.1.0-1.1         @home_sebix_intelmq       5.2 M
 python3-sleekxmpp       noarch       1.3.3-2.5         @home_sebix_intelmq       3.7 M

Transaction Summary
Remove  1 Package (+5 Dependent packages)

Installed size: 21 M
Is this ok [y/N]:

-----Mensagem original-----
De: Sebastian Wagner <wagner at cert.at> 
Enviada: 18 de junho de 2020 12:20
Para: Marco Paulo Machado Teixeira <marco at scom.uminho.pt>; intelmq-users at lists.cert.at
Assunto: Re: [Intelmq-users] IntelMQ on CentOS7 - yum update failling with conflicting files

Dear Marco, 

On 6/18/20 12:58 PM, Marco Paulo Machado Teixeira wrote: 
> Trying to update my intelmq install, on CentOS 7, with RPM packages
(as per the install instructions). 
I haven't even updated the RPM repository yet with the 2.2.0 release. 
> I'm getting a conflict with overlapping RPM packages from EPEL repo
and HOME:SEBIX:INTELMQ repo, with the following error (first line only, several more lines below I didn't copy). Already searched the web without luck. Also tried using REPO priorities but did not solve it.
Anyone has some advice on the best way to fix this without ruining the RPM database consistency? Or maybe some pointers where to look?

> ===
> Transaction check error: 
>   file /usr/lib/python3.6/site-packages/dns/__init__.py from install
of python36-dns-1.16.0-1.el7.noarch conflicts with file from package python3-dnspython-1.15.0-3.6.noarch

> ===

You can remove python3-dnspython. 

Short explanation: In the past I had to package dnspython myself (package python3-dnspython), as EPEL/CentOS did not have that package. 
With CentOS' Python 3.6 Upgrade, EPEL ships dnspython itself (as package python36-dns). 

There's no RPM database consistency, just two packages with conflicting files and RPM found and prevented the conflict, just as a good package manager should. 

best regards

// Sebastian Wagner <wagner at cert.at> - T: +43 1 5056416 7201 // CERT Austria - https://www.cert.at/ // Eine Initiative der nic.at GmbH - https://www.nic.at/ // Firmenbuchnummer 172568b, LG Salzburg 

More information about the Intelmq-users mailing list